Resolved
Workspaces in EU have been starting normally. And we think the issue is over.
Monitoring
We switched the LB back to EU. Waiting for the change to take effect.
Monitoring
We switched the load balancer to US, it could cause higher latencies and loading times for EU users as a side-effect. We're monitoring and working through the problem.
Identified
After further investigation, we've found that the root issue is with GCP network/image registries.
Identified
We've identified that a single bad node, we're working on fixing it.
Investigating
We've identified poor workspace performance in the EU region. We're investigating the issue.