Degraded workspace performance
Incident Report for Gitpod
Resolved
The issue is observed as resolved, performance has returned to normal.
Posted Apr 14, 2022 - 20:48 UTC
Monitoring
We've released a fix, all workspace starts will be done now using the new generation of clusters. The new clusters mitigate the performance issue. We are actively monitoring.
Posted Apr 14, 2022 - 17:53 UTC
Update
We're steadily shifting traffic from us39a to us40, and eu39b to eu40. These new clusters better handle load and provide improved performance.

Also, we're building a new set of clusters to replace eu39bxl and us39xl, more updates to follow.
Posted Apr 14, 2022 - 14:56 UTC
Update
This incident is still ongoing. Users are experiencing degraded performance during peak load times. Some (including Gitpodders) have even experienced data loss, for which we are terribly sorry. We are testing fixes internally, and will deploy when confident. Additionally, we will share a transparent blog post to help rebuild your trust.
Posted Apr 13, 2022 - 17:09 UTC
Identified
We've isolated the problem, and are testing a fix.
Posted Apr 12, 2022 - 13:39 UTC
Investigating
We've spotted degraded performance with workspaces, and are investigating solutions.
Posted Apr 12, 2022 - 13:14 UTC
This incident affected: Workspaces.