Resolved
The issue is resolved, we're starting workspaces in the US region on cluster us89b.
Identified
We've fixed the issue that caused workspace starts to fail in the US region. We're finishing some clean-up, and are still starting related workspaces in the EU region.
Investigating
We've identified poor workspace performance in the US region. We're investigating the issue.As a mitigation, we've redirected workspace starts to the EU region.