Workspace public ports are unavailable and IDE PORTS-UI anomalies
Incident Report for Gitpod
Resolved
Ports detection working normally in all clusters.
Posted May 02, 2023 - 17:27 UTC
Monitoring
US and EU clusters have been rolled back, and ports detection should be working as expected on both.
Posted May 02, 2023 - 06:08 UTC
Identified
We have found that the new generation clusters do not include exposed ports information. We are rolling back and will be fixing it in the new clusters.
Posted May 02, 2023 - 05:36 UTC
Update
Only US workspaces are affected. EU clusters remains unaffected.
Posted May 02, 2023 - 04:16 UTC
Update
We are able to reliably reproduce the issues. The incident has been escalated and now awaiting for a fix.
Posted May 02, 2023 - 02:44 UTC
Investigating
We've spotted that something has gone wrong with our ports mechanism. We're currently investigating the issue, and will provide an update soon.

Ports visibility can't be set to public from the IDE-UI (e.g. vscode) or `gp ports` CLI command.

Some users also reported that the IDE-UI (e.g. vscode) PORTS panel infinitely shows "detecting..." after each open port.
Posted May 02, 2023 - 01:32 UTC
This incident affected: Workspaces.