Joining organizations is returning an error
Resolved·Degraded performance

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Wed, Apr 23, 2025, 02:54 PM
(2 months ago)
·
Affected components
[PAYG] Dashboard
Updates

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.

Wed, Apr 23, 2025, 02:54 PM

Identified

We've identified the cause of the regression, and we're in the process of releasing a fix.

Wed, Apr 23, 2025, 01:29 PM(1 hour earlier)

Investigating

We've detected that joining organizations is returning a Not Found error. We're investigating the issue.

Wed, Apr 23, 2025, 01:11 PM(18 minutes earlier)