Between 5:20 UTC and 12:36 UTC we had misconfigured the location for Gitpod’s workspace backups.
Backups are taken when a workspace is stopped and they are restored when you reopen a workspace.
You are affected only if you have stopped and thereby backed up a workspace before 5:20 UTC today AND you have reopen this workspace during the incident.
Impact 1: The old backup could not be found, as such you got a new git clone without your changes.
Impact 2: Changes you made after you reopened the workspace are still backed up, but in the wrong location. If this affects you please reach out to us at support@gitpod.io and we will make sure you can recover your uncommitted changes between 5:20 UTC and 12:36 UTC.
We are very sorry for the trouble this has caused to our users.
Resolved
Between 5:20 UTC and 12:36 UTC we had misconfigured the location for Gitpod’s workspace backups.
Backups are taken when a workspace is stopped and they are restored when you reopen a workspace.
You are affected only if you have stopped and thereby backed up a workspace before 5:20 UTC today AND you have reopen this workspace during the incident.
Impact 1: The old backup could not be found, as such you got a new git clone without your changes.
Impact 2: Changes you made after you reopened the workspace are still backed up, but in the wrong location. If this affects you please reach out to us at support@gitpod.io and we will make sure you can recover your uncommitted changes between 5:20 UTC and 12:36 UTC.
We are very sorry for the trouble this has caused to our users.
Identified
We found the root cause of the issue and still working on the fix.
The good news is: There is no data loss. All data is safe. We still need some time to restore all the data.
Investigating
We believe we have found the root cause and are working to implement a fix. For the time being, please do not re-start workspaces older than today 06:00 CEST.
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
See also: https://github.com/gitpod-io/gitpod/issues/4671