Some workspace starts fail on image pull
Incident Report for Gitpod
Resolved
We finished rolling out the fix to both regions yesterday, August 4th, and have confirmed this is resolved.
Posted Aug 05, 2022 - 12:00 UTC
Identified
Good news! We've got a promising fix, and plan to deploy and monitor in the US region on Wednesday. The deploy to the EU region will be contingent on success in the US region.
Posted Aug 03, 2022 - 00:24 UTC
Update
We're still seeing this issue intermittently manifest itself in `eu54`, and are working on a fix. A couple potential solutions were tested today in `us58`, but, they did not perform well enough. We'll share an update again tomorrow!
Posted Aug 01, 2022 - 21:51 UTC
Monitoring
We've released a fix for stuck workspaces and prebuilds in the US region; we will monitor this fix over the weekend to verify this issue has been resolved. Once we've confirmed everything's working as expected we'll deploy this change to the EU region.
Posted Jul 29, 2022 - 22:53 UTC
Update
We have isolated an issue with workspace prebuilds and are preparing a test to fix the issue.
Posted Jul 29, 2022 - 19:55 UTC
Update
We are continuing to investigate this issue.
Posted Jul 29, 2022 - 18:47 UTC
Update
We are continuing to investigate this issue.
Posted Jul 29, 2022 - 18:44 UTC
Investigating
Some users have reported that they're having trouble starting workspaces in the EU region, and when this happens the error indicates image pull trouble. We're investigating, more updates to follow!
Posted Jul 29, 2022 - 18:43 UTC
This incident affected: Workspaces and Prebuilds.