Users can no longer log in with GitLab
Incident Report for Gitpod
Resolved
Since Saturday we no longer see issues with logins using gitlab.com. We will follow up with GitLab to identify the root cause and improve on our end if possible.
Posted Aug 15, 2022 - 10:59 UTC
Monitoring
We did not see the GitLab login error for at least two hours, and we'll keep monitoring it.
Posted Aug 13, 2022 - 14:27 UTC
Update
Please follow up the GitHub issue https://github.com/gitpod-io/gitpod/issues/12114
Posted Aug 13, 2022 - 08:58 UTC
Identified
It seems like GitLab issue, so we will file an issue to Gitlab to ask for further help. Unfortunately, there is nothing we can do at this point, so we keep the incident open to continue monitoring the situation. Worst case, it's probably okay to leave this as is until Monday and investigate this problem further.
Posted Aug 13, 2022 - 06:54 UTC
Update
Logging in to Gitpod with a GitLab account started failing at around 2022-08-13 @ 01:45 UTC. Our logs indicate that "the provided authorization grant is invalid, expired, revoked, does not match the redirection URI used in the authorization request, or was issued to another client". While we're actively investigating this problem, a workaround is to log in with a GitHub or Bitbucket account instead.
Posted Aug 13, 2022 - 05:27 UTC
Investigating
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Aug 13, 2022 - 04:51 UTC
This incident affected: Dashboard.