Gitpod Flex API failure

Incident Report for Gitpod

Resolved

We identified and addressed the root cause.
Posted Apr 04, 2025 - 18:09 UTC

Monitoring

We apologize for the delayed update. Earlier today, Gitpod Flex experienced an unexpected issue causing some APIs to fail. We have reverted to a previous stable version, and the service is now recovering. If your environment remains in an error state, please restart it to restore normal functionality.

We will continue to closely monitor the situation. Thank you for your patience and understanding, and we apologize for any inconvenience caused.
Posted Apr 04, 2025 - 17:31 UTC
This incident affected: [FLEX] Management Plane.